This week in OpenSim Dev – week ending 8th December 2012

Hello everybody.  This is a summary of the weeks of development in OpenSimulator.  Except where otherwise specified, the changes described here appear only in OpenSimulator’s cutting edge Git ‘master’ branch. Only changes that I think will be interesting to end users are listed.  Please do not attempt to use code taken directly from ‘master’ in any production environment.  Sometimes this in-development code may not work or may even cause data corruption. If you are not a developer or tester, please treat this summary instead as a preview of what will be coming up in the next release. The latest official release is OpenSimulator 0.7.4 (released on August 31st, 2012).

The letters and numbers in brackets after some entries tell you the latest git commit to which they apply.

This week in OpenSim ( 10fcc70 - a37040d ).

General news

  • None this week.

Features & bug fixes

  • Robert Adams of Intel continued to work on the BulletSim physics engine plugin, this week looking at collisions, vehicles, materials (f9fed42).
  • Diva Canto of UCI improved the HypergridInstantMessage service to account for the existing of an offline IM storage service (583e441).
  • I added a processed events statistic for each script instance, which can be seen using the “show scripts” or “show script” console commands.  I also added the total processed events to the “xengine status” output for debugging/analysis purposes (ec765de).
  • I fixed an issue where OpenSimulator was not properly handling HTTPGetTexture capability calls with no second value in the range header (e.g. just 5333- to request all bytes from 5333).  It appears that the latest viewer code has started to do this,  I also ported this fix to the 0.7.4-post-fixes and 0.7.3-post-fixes git branches (acc01bb).

Infrastructure

  • No news this week.

3 comments for “This week in OpenSim Dev – week ending 8th December 2012

  1. December 13, 2012 at 3:54 am

    great job everybody and take some time off for the holidays!

    don’t get burned out! =)

  2. December 17, 2012 at 7:18 pm

    Hi
    I have tried to install OpenSim but no matter what I try, I cannot connect to it from a Windows client nor any Mac client. The suggested connection parameter loginuri is not available anymore. Tried the SL client and tried Firestorm, none works. Any idea what I did wrong?

  3. justincc
    December 17, 2012 at 10:49 pm

    @Ener – Thanks – I will certainly be taking a nice holiday over Christmas.

    @Jan – I’m afraid I can’t help you with that here since there are many things that can go wrong. I suggest you try one of the other viewers at [1] or failing that ask in places like the opensim-users mailing list or osgrid forums. You should also try connecting your viewer to an established grid first (like osgrid).

    [1] http://opensimulator.org/wiki/Connecting

Leave a Reply

Your email address will not be published. Required fields are marked *